QuickBooks Ruby Newsletter

Issue 25 August 1st, 2017


Intuit took many by surprise in implementing and requiring OAuth2 for developer accounts created on or after July 17th.

Here is what I know.

  • If you have made an existing developer account you're fine for probably a good while. Even new apps you create on your existing developer account will be OAuth 1a. If you are going to be making a new QuickBooks app and what to use OAuth2 then you must make a new developer account.
  • Us library authors were definitely taken off guard as the issues started filing in. I have upgraded QboApi and Cody has started on getting quickbooks-ruby updated as well.
  • There is some indication (read linked article) that there will be a migration path to OAuth2 for existing accounts. Watch out that Intuit might turn this notion into a forced migration.
  • I have a basic article released and will have more around persisting and renewing OAuth2 access tokens.

  Twitter | LinkedIn  
Copyright © 2017 Minimul, All rights reserved.
You are receiving this email because you opted in at my website http://minimul.com.

Need to integrate with QuickBooks?

.. or tired of features being put on hold while your team burns time on QuickBooks integration?
Have an idea for the Intuit App store?
Contact me. I have been there, done that, when it comes to QuickBooks integration.